SPCR
http://www.silentpcreview.com/forums/

Ivy bridge + XP = ultra slow?
http://www.silentpcreview.com/forums/viewtopic.php?f=28&t=65234
Page 1 of 1

Author:  Luke M [ Sat Oct 20, 2012 8:18 am ]
Post subject:  Ivy bridge + XP = ultra slow?

I upgraded from a 10 year old Pentium 4 to a 3.3Ghz Ivy bridge and, at least for now, I'm still running XP. It works, but the integrated Intel HD4000 graphics feels slow compared to the 10 year old PC. Moving windows, console scrolling, etc. Worst of all, the mouse cursor feels slow.

Is this a known problem with the Intel graphics? Would Windows 7 or 8 run better?

Author:  CA_Steve [ Sat Oct 20, 2012 12:15 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Should work fine. More likely, something isn't set up properly... See any question marks when you dive into the device manager? Or, maybe a RAM stick failed and your are trying to run with only 1-2GB of RAM...:)

As for Win7 vs Win XP: I heartily recommend Win7. A lot of the boneheaded crap/issues just went away when I upgraded.

Author:  edh [ Sat Oct 20, 2012 1:37 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

CA_Steve wrote:
Or, maybe a RAM stick failed and your are trying to run with only 1-2GB of RAM...:)

Should make no difference. Windows XP will only use around 100Mb in itself. More than a few hundred Mb would not effect a typical desktop system before any applications are loaded. An inability to handle a non-composting window manager within the drivers is one possibility or maybe the drivers don't work properly on Windows XP. Have you tried benchmarking anything? Look up some graphics benchamrks for the 4000 series graphics and see how yours compares. It could be that hardware acceleration is entirely broken in your setup, even in 2D. Is this a new Windows install or not? A motherboard change is the kind of thing that can cause a Windows install to give up on life.

Author:  Luke M [ Tue Oct 23, 2012 6:32 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

I found this helpful benchmark:

http://www.tomshardware.de/download/Tom ... 26150.html

It confirms that Ivy bridge HD4000 really is very slow (much slower than a 1.8Ghz Pentium 4 with nvidia 6200 - low end 64-bit card from 2005).

Here's something else which is crazy. Ivy bridge is much faster if hardware acceleration (in the Windows settings) is completely disabled. Unfortunately, this prevents all DirectX apps from running.

Author:  washu [ Tue Oct 23, 2012 7:37 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Luke M wrote:
I found this helpful benchmark:

http://www.tomshardware.de/download/Tom ... 26150.html

It confirms that Ivy bridge HD4000 really is very slow (much slower than a 1.8Ghz Pentium 4 with nvidia 6200 - low end 64-bit card from 2005).


There must be something very wrong with that benchmark then. While the HD4000 is not fast compared to modern high end cards, it is much faster than a 6200.

Edit: Either that or the video drivers are not installed properly. Running on the default VGA driver would cause the problems you are seeing.

Author:  m1st [ Tue Oct 23, 2012 7:48 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

washu wrote:
Luke M wrote:
I found this helpful benchmark:

http://www.tomshardware.de/download/Tom ... 26150.html

It confirms that Ivy bridge HD4000 really is very slow (much slower than a 1.8Ghz Pentium 4 with nvidia 6200 - low end 64-bit card from 2005).


There must be something very wrong with that benchmark then. While the HD4000 is not fast compared to modern high end cards, it is much faster than a 6200.

Edit: Either that or the video drivers are not installed properly. Running on the default VGA driver would cause the problems you are seeing.


+1

http://www.anandtech.com/show/5771/the- ... k-review/9

Another example of what you should expect from the HD4000. Should have similar performance to contemporary discrete cards costing ~$60. I'm pretty sure something's wrong with the install.

Author:  CA_Steve [ Tue Oct 23, 2012 9:32 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

+1

Author:  Luke M [ Tue Oct 23, 2012 9:54 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

I guess I wasn't clear. I'm talking about 2D performance, not 3D games. Game tests are totally irrelevant. I haven't even tried running a 3D game. The benchmark I linked to is a 2D (normal Windows API) benchmark.

Author:  Pappnaas [ Tue Oct 23, 2012 11:28 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Even Intel GMA950 could do internet browsing or 2D scrolling without any hick ups at 1080p.

I guess it's a driver problem. Install latest chipset driver, reboot. Install latest VGA driver, reboot. Then see what happened.

Author:  Luke M [ Wed Oct 24, 2012 1:02 am ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Ok, I think I figured out the problem, or at least part of it. I use a rotated screen (1080x1920). When in 'normal' orientation (1920x1080), the 2D performance is fine. It's only super slow when rotated.

Author:  Luke M [ Wed Oct 24, 2012 5:18 am ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

More discoveries: the slow mouse cursor is a different problem, not caused by slow graphics. Changing USB ports from Intel Z77 to ASMedia USB3 controller makes the mouse work normally. Intel doesn't supply USB3 drivers for XP, so generic Microsoft USB2 drivers are being used for those ports...it should work, but maybe there is a subtle bug.

Author:  CA_Steve [ Wed Oct 24, 2012 7:04 am ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

I haven't come across any specific problems regarding slow 2D in portrait mode for the HD 4000. My best suggestions are to see if your BIOS is current (there were flickering issues with the HD 4000 that were solved by updating the memory manager in bios) and the graphics driver is current. Also, pop into the Device Manager and see if the display adapter is correctly enabled.

Author:  Luke M [ Wed Oct 24, 2012 1:31 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

From what I could tell from searching the Intel documentation (http://intellinuxgraphics.org/documentation.html), the Intel graphics hardware doesn't directly support rotation, except for 180 degree rotation. And indeed, 180 degree rotation runs at full speed.

So my guess is that there's an inefficient conversion step involved. This makes it actually slower than unaccelerated software rendering, which explains why it speeds up when acceleration is disabled.

On my ancient nvidia card, the performance is the same whether the screen is rotated or not!

I've never seen any rotated benchmarks published anywhere...

Author:  Ralf Hutter [ Thu Oct 25, 2012 6:16 am ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Luke M wrote:
From what I could tell from searching the Intel documentation (http://intellinuxgraphics.org/documentation.html), the Intel graphics hardware doesn't directly support rotation,...


But that's in Linux.

I haven't (and probably never will) tried rotating my monitor, but according to all I can see in the "Intel Graphics and Media Control Panel" of my i3-3225 system, it supports 90, 180 and 270 degree screen rotations. You can change it on the fly using a drop-down box right on the application itself. This is on Win 7 64-bit though.

Author:  Vicotnik [ Thu Oct 25, 2012 8:05 am ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Tried to tilt the screen on my system running Xubuntu 12.10. Seems to work without slowdown as far as I could tell. Perhaps xfce4 isn't that heavy though.

Author:  edh [ Thu Oct 25, 2012 1:10 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Ralf Hutter wrote:
But that's in Linux.

If the hardware doesn't support it, then it doesn't matter what the OS is, it will be down to the driver to run it through software, hence the slow performance.

Author:  Luke M [ Mon Oct 29, 2012 12:48 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Here's another performance fact. 16-bit color vs 32-bit color makes almost no difference when not rotated. But when rotated, 16-bit is much faster.

Author:  Luke M [ Mon Oct 29, 2012 3:50 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Another thing I found out...Intel completely dropped support for Vista. Sandy bridge supported Vista, but Ivy bridge doesn't.

Author:  Pappnaas [ Mon Oct 29, 2012 11:03 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Why should intel? They bring the latest WinXP and the latest Win7 drivers. Those still using vista probably never update their drivers anyway.

Author:  Luke M [ Tue Oct 30, 2012 3:58 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Pappnaas wrote:
Why should intel? They bring the latest WinXP and the latest Win7 drivers. Those still using vista probably never update their drivers anyway.


I don't think you understand. There is NO vista driver.

Author:  washu [ Tue Oct 30, 2012 4:14 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Luke M wrote:
I don't think you understand. There is NO vista driver.

While there is no "official" driver for Vista, there is no reason the 7 driver would not work. A quick google appears to show that it does. Not supported doesn't always mean it doesn't work.

Author:  Pappnaas [ Tue Oct 30, 2012 10:15 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Luke, Vista is microsofts ugly child. They nearly deny it ever existed. Besides, i have some PCs running Vista and they do work stable. But using Win7 is a more pleasant experience. Most Win7 drivers do work on Vista and the other way around.

Author:  Luke M [ Tue Oct 30, 2012 10:46 pm ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

washu wrote:
Luke M wrote:
I don't think you understand. There is NO vista driver.

While there is no "official" driver for Vista, there is no reason the 7 driver would not work. A quick google appears to show that it does. Not supported doesn't always mean it doesn't work.


Thanks for the info.

Author:  Luke M [ Wed Oct 31, 2012 6:26 am ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

This is crazy. I found that the graphics speeds up if I add a second monitor.

Plug in 2nd monitor -> faster!
Unplug 2nd monitor -> very slow again

Maybe adding the second monitor disables some driver "acceleration"?

Author:  Vicotnik [ Wed Oct 31, 2012 6:34 am ]
Post subject:  Re: Ivy bridge + XP = ultra slow?

Different idle frequencies for graphics core and memory depending on number of monitors connected is normal. It should not be any noticeable difference in 2D performance though.

Page 1 of 1 All times are UTC - 8 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/