It is currently Fri Jul 25, 2014 11:41 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 25 posts ] 
Author Message
 Post subject: New here and I have some ideas I want critiqued
PostPosted: Wed Oct 06, 2004 7:12 am 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
I am new to this forum and looking for ideas... I have been reading the site for a couple of weeks and now feel I could use some advise. This is my first post.

I am building a HTPC and recently started assembly. What I ran into was a noisy power supply and no way to replace it. I bought a CoolerMaster Cav 2 which uses a now standard size ATX power supply. I want to change out the 80mm fan with a 92mm fan that I can run slower. I am hesitant because I can not seem to find someone who sells the installed power supply or one that fits. I have emailed CoolerMaster and they said the will shortly be releasing a 350 watt power supply so when that comes I may pick one up just to mod. I would assume that running a 92mm fan at 7 volts would be quieter then what I have now....

Next area I am contemplating is case cooling. This case has one 80mm intake and two 60mm exhaust fans. I swapped the intake out with a Panaflo FBA08A12M and the exhaust with 2 Vantec TF6025's. I am looking at fan controllers now as I would like to be able to adjust the speed of the fans for time of the year. Any recommendations ?? I was thinking of cutting the two grills for the 60mm fans out and soft mounting the fans. Is this a good idea?? Are there quieter 60mm fans I may want to look at?? I was also thinking of cutting the intake opening and soft mounting a 92mm fan under volting it. Does this sound like a good idea?? Any recommendations about quiet fans that move lots of CFM would be great (I know this one you probably get often and I should not ask). The other idea I had was to add another 80mm exhaust fan on the opposite side of the case as the intake fan and under volt that. I would have to be a thin fan though as I do not have much room (I can get a full 80mm in but it touches the frame a bit... there is an open direct airway to where I want to mount it.) What are some quiet low profile 80mm fans ?

Right now I am running at : CPU 35 degrees idle and 38 under load (with a Spire WhisperRock IV with a Panaflo FBA08A12M which I plan to under volt also) : case stays around the same as CPU

I already have some sound damping material that I will be installing once I have decided on where and what is going to get cut.

Any and all ideas and comments welcomed. If I violated any forum etiquette I apologize in advance.

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 7:23 am 
Offline
*Lifetime Patron*

Joined: Wed Nov 12, 2003 10:06 am
Posts: 3214
Location: Pittsburgh, PA
Eh, what sort of PSU dimensions are necessary? It may be a lot easier to simply get a new PSU rather than replace the fan with a different sized fan.

I don't think there are any quiet 60mm fans out there. Maybe SilenX/Adda. Though cutting out fan grills is always good for better airflow.

As for fan controllers, I generally prefer the cheap linear regulated fan controllers. The ones that don't even have a manufacturer. They're usually more than good enough for any basic fan controlling.

One thing I'm curious about is why you want more/better case cooling. Your processor temps are downright impressive. Hard drive temps would be the only thing I'd be worried about.

_________________
My Power Rig, Storage Rig, HTPC and Main Rig


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 7:46 am 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
wow thanks for the quick reply.. the power supply is a macron mpt-301... but when I search for one the replies I get are not what is installed... It is about half and inch to an inch shorter in width then a standard atx...

I like to keep things cool... everything seems to last longer... those temps were for fans a full speed also... Once I get the fan controllers installed I think they will go up alot... I just want to be able to keep things quiet and cool...

thanks for you other comments....

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 8:34 am 
Offline
Site Admin

Joined: Sun Aug 11, 2002 3:26 pm
Posts: 11819
Location: Vancouver, BC, Canada
The PSU is a custom size; no choice but to try swapping the fan and cut the inside grill if you want it to be quieter. Don't try to squeeze in a 92mm fan; too much hassle, and the airflow improvement from 80 to 92mm is not very significant -- at least at low rpm / noise level.

cutting the two grills for the 60mm fans out and soft mounting the fans -- good idea. There are better 60mm fans, but I can't point a specific one out. Maybe the SilenX. These fans are probably among the most critical parts of your cooling system, so I'd pay a lot of attn.

The other serious problem in this case appears to be intake vents -- there are only 2, and they seem to have very restrictive grills. My guess is that those high fan speeds (and top vent for the CPU intake?) were absolutely necessary for you to achieve those temps.

Think of the airflow paths from the intakes to the hot components and exhaust ports. The less restricted these paths are, the slower you can run your fans while still keeping your components cool enough. Even though a bigger vent means more noise can get out, the reduction in noise at the sources more than makes up the difference.

I second sthayashi's comment on cheap voltage controllers -- see the Fans & Control section on the main site for reviews of some decent ones.

Don't be afraid to run the CPU temp up to 60C at load. They can all take it; lots of folks here run CPUs hot & never report a failure due to that. I've burned a couple AMDs but only to catastrophic failure -- HS not engaged properly. The only thing you really have to watch out for is the PSU fan ramping up because it's thermally controlled (probably) and the PSU intake is so close to the CPU.

Welcome to SPCR, btw. ;)

_________________
Mike Chin,
Editor/Publisher, SPCR
Support SPCR with your donations!


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 9:07 am 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
thanks for you comments...

Any recommendations as to a fan for the PSU fan?? should I try and controll it or get one with a temp probe like the acoustifan??

I was thinking of tieing the top vent directly into my down dafting CPU fan.... you can see the bottom of the vent here:

Image

It would not be two hard and then cold air would be brought in right to the CPU.... sounds like a good idea...

without that vent for exhaust venting I figured I would need to add a additional vent... you can see the whole in front of the power supply and behind the 5.25" drive bays.... thats where I would want to mount the fan...

I will probably remove the stock side intake grills and use wire ones... to keep kids from jamming things in there :)

Image

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 9:18 am 
Offline
Site Admin

Joined: Sun Aug 11, 2002 3:26 pm
Posts: 11819
Location: Vancouver, BC, Canada
A PAnaflo 80L or 80M will work fine. The Nexus is also very quiet but does not start consistently at 5V (which might be an issue depending on the start voltage of your PSU -- tho the temp will rise and the fan voltage will rise quickly enough to make the fan start in a few minutes...)

I doubt that extending the top duct to the CPU will make that much difference; it's already so close anyway. I'd guess most of the air to the CPU probably comes from that top duct already: Air moves like water, it takes the shortest path, and that top duct is much closer than any of the others.

You might also enlarge the vent on the other side and install another intake fan. Or maybe cut a vent on the bottom panel near/beneath the HDDs and leave it as a passive intake. One extreme move would be to flip the PSU 180 degrees so that its intake fan is facing the side and cut a hole in the case for that fan. Then the PSU would be taking in only cooler outside air and its fan will rarely ramp up in speed.

_________________
Mike Chin,
Editor/Publisher, SPCR
Support SPCR with your donations!


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 12:50 pm 
Offline

Joined: Fri Jun 06, 2003 9:40 am
Posts: 636
Location: USA
Mike said it all, can't think of anything else but welcome. :)

Mike C. thanks for the reminder about going up to 60c with no problems, I'd forgot how high we can go.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 6:48 pm 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
thanks for all you ideas and comments... this really helps

I really like the idea about flipping the power supply... getting outside air to cool it would make life much easier.... I would only worry about exhaust without it pulling air from the case... the two 60'2 will have there work cut out for them...

I do not think my power supply ramps the fan as it seems to get to one RPM and stay there... I can only tell this by sound though so I am not sure... I assume I will have to control the fan with an external controller in order for it to run slower then stock...

I was looking at fan controllers and saw the VL System Zephyrus... anyone have any experience with it?? for a HTPC with a door over the drive bays it looks like a good option.

I was running by xp-m 2200 @ 2000 mhz when I posted my last temps... I have changed it back to 1600 mhz and dropped voltage to 1.325 from 1.425... funny thing... now my cpu is colder then my case... which makes me think I willl have to move more air... I will re-evualte this after removing the grills...

thanks again

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 11:26 pm 
Offline

Joined: Tue Mar 09, 2004 9:05 am
Posts: 1443
Location: Turkey
cleb,

If I'm not mistaken you have two fanclips holding the 60s in place. Those make noise. Hardmounting them with grommets might solve some issues.

I don't know about the 60 versions but I really don't like any of my other size Vantecs. They're both noisy and emmit a lot of vibration. I've always been impressed with the 60mm delta fans that come stock with Athlons. They have little vibration, undervolt nicely and move a surprising amount of air. They're thin though, that might be a problem. I also kind of remember Dorothy (our esteemed supplier of Panaflos for nonUS) recommending them.

Again, if I remember correctly, the PSU is a single fan PSU that pulls air from the inside and exhausts to the outside. If that's the case, that's one restrictive looking grill, you might try a wire grill.

_________________
Thor's Hammer
Loki's Magic: Coming soon...
Odin's Chariot


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 06, 2004 11:58 pm 
Offline

Joined: Thu Jul 15, 2004 12:44 pm
Posts: 380
Location: UK
Just to set your mind at rest, my Athlon XP2000+ regularly idles at 68C and when gaming reaches 73C.
I have had it running like that for 2 years and not once has the system crashed due to overheating. I'm a habitual fiddler so it's crashed plenty of times due to me playing with drivers and things - on one memorable occasion I actually managed to force windows xp to install some windows 98 drivers by accident - the results were interesting.
However, it is perfectly stable.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 07, 2004 2:34 am 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
thanks all

That grill is definitaly going.... I am just waiting for CoolerMaster to tell me where I can find a replacement... I am going to swap out the fan also but do not want to until I know I can get a replacement power supply if I have problems....

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Thu Oct 07, 2004 8:56 am 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
So I was looking through the forum some more getting information about SilenX fans which from there web site and reviews outside this forum look very good.... but it seems like people here do not like them... are they any good or are they junk?? & why do people dislike them?

thanks

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 08, 2004 11:04 am 
Offline

Joined: Tue Mar 09, 2004 9:05 am
Posts: 1443
Location: Turkey
Unacceptable business practices.

I wasn't around when everything happened but having read the relevant threads, I'd only buy from them if they were the only vendor for the technology and my life depended on it. Neither is true, so for me, they're out.

btw, from what I've gathered their products aren't bad at all but their dBA spec are total BS not to mention their airflow values are suspect as well.

_________________
Thor's Hammer
Loki's Magic: Coming soon...
Odin's Chariot


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 08, 2004 11:28 am 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
So I removed the rear grills and soft mounted the two fans... I also put the hole in so I can flip the power supply... I picked up a couple of these :

Image

One for a new power supply intake and one for a exhaust. Which will be in front of it a little bit.. is the hole infront of the power supply

Image

I am thinking of adding a fan on the top of the case to replace the vent but I will wait until I see how things are doing before adding it.

I have new grills on the way also So I will be replaceing the stock ones on the power supply and case.

On Monday I think I am ordering the VL Systems Zephyrus

Someone mentioned drive temps... my two drives run 28 degrees and 38 degrees... These do not sound to high... but I do not know hot hot drives should run.

So if I should stay away from SilenX where is a good place to buy the adda fan??? I only found one place...

thanks for all your help

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 10, 2004 9:23 am 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
Made some more changes and and now running cooler & quieter then ever...
1) Opened the PSU and removed the grill and replaced the fan with a Panaflo 80L (just over 3 bucks from BG Micro - great price)
2) removed the grill from my CPU cooler
3) replaced the Panaflo 80m with a Panaflo 80L for my front intake
4) removed the
Image

and added another Panaflo 80L pushing cool air right on my CPU...

all fans are still running at 12v until I get my fan controller next week... My temps are:
Code:
        IDLE        LOAD (30 minutes w/ CPU burn)
CPU     32          34
Case    35          37
HD 1    25          27
HD 2    38          42


Cooled back down to idle in a couple of minutes...

I think I have plenty of head room now to slow the fans down... I am still looking for 2 quiter 60mm fans... The one place that sells the adda's is pretty pricey.... So I am looking for other places still...

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 10, 2004 11:31 am 
Offline

Joined: Tue Mar 09, 2004 9:05 am
Posts: 1443
Location: Turkey
I find it very suspect that there's only 2C difference in CPU temps between idle and 30 mins of CPU Burn. There must be something wrong. Or you're reading the wrong temps. Check everything.

As a comparison. My Athlon64 3000+ @ 1.5V runs at 44C with the huge Zalman on top at idle. 30mins of CPU Burn take it all the way up to 84C. That's 40C difference. If I turned up the fan speed that difference would probably go down but 2C is impossible IMO.

_________________
Thor's Hammer
Loki's Magic: Coming soon...
Odin's Chariot


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 10, 2004 1:04 pm 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
I dropped the voltage to 1.275 (fsb 133 x 12.5 = 1667) on my CPU and I am now only getting 33 degrees while running CPU BURN for 30 minutes.... not sure what to say... I tried rebooting right after to check the bios and it is the same as Mother Moard Monitor... might be the differnce between moble CPU's and standard ones... Might have something to do with ambiant temp... my house is 20 degrees right now ... any one else have any ideas?? also does should undervolting the CPU kept it much cooler... wondering how far it will go....

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 10, 2004 2:51 pm 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
I just ran prime95 for an hour and I was getting 35 degrees... with voltage at 1.275... my last run getting full load at 33 might have been a fluke... everything confirmed in the bios to be the same via restart after run...

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 11, 2004 5:45 am 
Offline
Friend of SPCR

Joined: Mon Apr 28, 2003 4:37 am
Posts: 1310
Location: Finland
What SpeedFan reports for temps? Include all readings.

Cheers,

Jan

_________________
E6600 (2GHz@1,163V, 3GHz@1,237V), Ninja rev. B, AB9 Pro, 4x1 GB Corsair (CM2X1024-6400), MSI 7600GS, Samsung HD501LJ/HD401LJ/SP2504C, Plextor PX760SA, Seasonic S12-430, Nexus Fans, Antec Solo, ViewSonic VP201b


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 11, 2004 11:47 am 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
I took screen shots of my last run (you can click on them to get large versions):

idle :

Image removed for faster loading

load (30 minutes with CPU burn - screen shot taken just before completed):

Image removed for faster loading

I confirmed both the idle and load temp in the bios by checking just before starting and just after completing... looks good to me...

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Last edited by cleb on Tue Oct 12, 2004 5:59 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 11, 2004 11:59 am 
Offline

Joined: Fri Jul 23, 2004 11:10 pm
Posts: 657
Location: AB, Canada
using mbm + speedfan could be breaking it, should only run one at a time... and on top of that, look at speedfan, that sensor changing from 30->32C doesn't look like the CPU. :P


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 11, 2004 12:22 pm 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
I am running it again right now without mbm running but if they are off they are off everywhere... I assume what I see in the bios is the most accurate... is this correct?? I had this overclocked before and the CPU temp was higher then... so I think what I am reporting is accurate...

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 11, 2004 12:54 pm 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
Here is with just powerfan runnig:

Before - idle :

Image removed for faster loading

After - 30 minute run of CPU burn... screen shot taken just before complete:

Image removed for faster loading

again both confirmed in BIOS...

so are these legit or not ??

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 12, 2004 6:49 pm 
Offline

Joined: Wed Oct 06, 2004 6:06 am
Posts: 23
Did a third run of things today after removal of the front air intake grill...

startup (taken as soon as system was up):
Bios temps were on startup - case 25 degrees - CPU 24 degrees after sitting cold for several hours

Image

Just before run after about ten minutes of warm up time:

Image

End of run:

Image

so do these numbers look ligit... or do the look off??

thanks

_________________
NFII ULTRA INFINITY
AMD XP-M 2200 @ 2004 mgz w/ Spire WhisperRock IV w/ Panaflo FBA08A12M
Cosair 512mb 3200 x1 valueram
nVidia GeForce 4 MX 440
CoolerMaster Cavalier 2 w/ 1 Panaflo FBA08A12M intake & 2 Vantec TF6025 exhaust
Samsung SP1614N + MAXTOR 6Y080L0


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 12, 2004 8:07 pm 
Offline

Joined: Fri Jul 23, 2004 11:10 pm
Posts: 657
Location: AB, Canada
weird, maybe then. maybe those sensors are completely irrelevant, a lot of boards have fake sensors that aren't really sensors (and give <0 temps, or the difference between two other sensors or other weird stuff). wtf is that thing stuck at 57C then?
and i wasn't saying mbm and speedfan should be giving different results, but that you shouldn't run any similar utils like that at the same time, since they can interfere with each other when trying to read the sensors.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 25 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: Exabot [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group