It is currently Sun Dec 28, 2014 4:49 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: 47 watt 7 TB server (disks spun down)
PostPosted: Fri Feb 05, 2010 3:45 pm 
Offline

Joined: Fri Sep 26, 2008 1:40 pm
Posts: 49
Location: Sweden/Stockholm
Motherboard: GA-MA74GM-S2H (6 SATA ports)
CPU: Sempron 1250, underclocket and undervolt 1 GHz
Mem: 1 x 1 gb stick
PSU: noname 300watt (6 years old)
HD:
4 x WD green edition 1TB
2 x WD green edition 1.5TB
1 x 30 GB IDE 2.5" (sys)

All sorts of tweaks in Bios, no sound/USB/gigabit etc.

With all 3.5" HD spun down and sys drive active idles at 47w with Ubuntu. All drive active, under 90 watt.

I hope I can go lower with a 300 watt modern PSU, off course I am aiming with at least four more hard drives this year too.

Critique my build, how can I save more energy.

_________________
Pegasos 2 G4 1GHz, 768 MB, AmigaOS4.1


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 05, 2010 4:08 pm 
Offline
*Lifetime Patron*

Joined: Thu Feb 13, 2003 6:53 am
Posts: 1544
Location: Sweden
Me and a friend are in the process of building a similar system for his needs, a NAS box using FreeNAS. We'll start with an old P3 system and see how it goes, then get a setup similar to yours if the P3 system fails to deliver the needed performance.

We will boot the system from a CF card rather than from a HDD and we will perhaps use something like a PicoPSU, depending on how many disks are needed.

Main reason for your high idle power consumption must be the PSU I think.

_________________
Main: ASRock B85M-ITX | i3-4330 | 16GB DDR3 | Intel 730 240GB | HDPLEX H1-S | picoPSU | No moving parts | Idle 13.9W
HTPC: ASRock H81M-ITX | Pentium G3420 | 4GB DDR3 | Intel 520 120GB | HDPLEX H1-S | picoPSU | No moving parts | Idle 11.2W
Gaming: Intel DH77EB | i5-3570K | GTX 750 Ti | 16GB DDR3 | Intel 520 120GB | TJ08-E | G-360 360W
Server: Intel DH77DF | i3-2100T | 4TB+3x3TB | picoPSU | Idle 24W AC


Top
 Profile  
 
 Post subject:
PostPosted: Sat Feb 06, 2010 5:51 am 
Offline

Joined: Wed Dec 30, 2009 9:13 am
Posts: 72
Location: Canada
Ive got the exact same motherboard and cpu as you. Ive noticed that you can't go any lower than 0.9v on the CPU or else you get stability issues. I get about 38-40W idling with no drives spun down, this is my setup (very similar to yours):

AMD LE-1250 at 1ghz, 0.9v
Gigabyte GA-MA74GM-S2
1 stick Corsair 2GB 667mhz DDR2 ram (underclocked to 400mhz)
2x 1TB WD Green
Antec EA380 PSU
BIOS Tweaks: Turned off anything unnecessary like IDE channels, serial port, parallel port, onboard audio, VGA and memory clock underclocked down to their lowest settings.

I bought a Winmate 120W DC-DC psu with an 89% efficiency power adapter, so maybe that 40W idling will go down even more. Im also curious how well all this heavy underclocking/undervolting will run WHS2 Vail when it comes out.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 07, 2010 9:05 am 
Offline

Joined: Fri Sep 26, 2008 1:40 pm
Posts: 49
Location: Sweden/Stockholm
Considering drives at idle runs at around 3 watt that is 34 watt for your system which I think is impressive.

I would chose CF-card too but I havent found a good Linux solid state installation yet that runs installation on auto-pilot.

I am planning to top out at 12-14 harddrives, I dont know what PSU I should get, considering drives will rarely spin all at the same time (besides boot).

My system is underclocked to 1 GHz and it is a bit slugish with my Truecrypt volumes, for example FTP is seriously slow when adding files to the volumes so I am thinking of restoring clock speed.

_________________
Pegasos 2 G4 1GHz, 768 MB, AmigaOS4.1


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 07, 2010 10:48 am 
Offline
*Lifetime Patron*

Joined: Thu Feb 13, 2003 6:53 am
Posts: 1544
Location: Sweden
erkan wrote:
I would chose CF-card too but I havent found a good Linux solid state installation yet that runs installation on auto-pilot.

What do you mean? A CF-card in a CF-IDE-adapter looks like any IDE HDD as far as I know. Skip the swap partition and you should be good to go, or am I missing something?

_________________
Main: ASRock B85M-ITX | i3-4330 | 16GB DDR3 | Intel 730 240GB | HDPLEX H1-S | picoPSU | No moving parts | Idle 13.9W
HTPC: ASRock H81M-ITX | Pentium G3420 | 4GB DDR3 | Intel 520 120GB | HDPLEX H1-S | picoPSU | No moving parts | Idle 11.2W
Gaming: Intel DH77EB | i5-3570K | GTX 750 Ti | 16GB DDR3 | Intel 520 120GB | TJ08-E | G-360 360W
Server: Intel DH77DF | i3-2100T | 4TB+3x3TB | picoPSU | Idle 24W AC


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 07, 2010 11:16 am 
Offline

Joined: Fri Sep 26, 2008 1:40 pm
Posts: 49
Location: Sweden/Stockholm
For how many years will you be good to go if you skip the swap-partition?

_________________
Pegasos 2 G4 1GHz, 768 MB, AmigaOS4.1


Top
 Profile  
 
 Post subject:
PostPosted: Sun Feb 07, 2010 3:11 pm 
Offline
*Lifetime Patron*

Joined: Thu Feb 13, 2003 6:53 am
Posts: 1544
Location: Sweden
Forever? Given you have enough RAM. I have never used a swap partition under Linux (in recent years anyway) and have always had the page file disabled under WinXP on my main system. Never had any problems with it.

Why would you need swap space on a file server?

_________________
Main: ASRock B85M-ITX | i3-4330 | 16GB DDR3 | Intel 730 240GB | HDPLEX H1-S | picoPSU | No moving parts | Idle 13.9W
HTPC: ASRock H81M-ITX | Pentium G3420 | 4GB DDR3 | Intel 520 120GB | HDPLEX H1-S | picoPSU | No moving parts | Idle 11.2W
Gaming: Intel DH77EB | i5-3570K | GTX 750 Ti | 16GB DDR3 | Intel 520 120GB | TJ08-E | G-360 360W
Server: Intel DH77DF | i3-2100T | 4TB+3x3TB | picoPSU | Idle 24W AC


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 08, 2010 7:46 am 
Offline

Joined: Thu Jul 31, 2003 1:57 pm
Posts: 32
Vicotnik wrote:
Forever? Given you have enough RAM. I have never used a swap partition under Linux (in recent years anyway) and have always had the page file disabled under WinXP on my main system. Never had any problems with it.

Why would you need swap space on a file server?


If you run out of dram the OOM reaper will start killing off processes, so you'll get some very mysterious symptoms. The other point is that Linux and especially the X11 bits (not needed on a file server) have been growing larger over the years, so do use "free" and "ps" to examine how much memory is being used. You might be better off creating a swap on a spun-down disk than having no swap at all. If that's unacceptable, then you should rebuild your kernel to panic rather than reap processes. It's better for a server to fail than to act 'twitchy' at random times.


Personally if I was using flash for the root, I'd mount it read-only. You can always "mount -o remount,rw .." when you need to change configs. You'll need to create a r/w /var in a ram partition some logs, pidfiles & such are spooled there. Also examine the "noatime,nodiratime" mount options and the "commit=" options for any flash r/w.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Feb 08, 2010 10:33 am 
Offline

Joined: Tue May 26, 2009 10:37 am
Posts: 187
Location: UK
i like the system, i plan to build somthing like this one day. i wana add a 2.5" hard drive to my server so the other ones can be span down all the time. right now i have 1 drive that is on 90% of the time



but i would also consider adding abit more ram so you can go without swap . none of my machines have swap, but they all have 4gb of ram

_________________
specs:E8400@4ghz,4gb ddr2 1066, DFI LP jr p45-t2rs,Super talent 64gb ssd,8800gts @ 513/792/1674, 8800gt @ 555/800/1782 corsair tx650
Cooling:XSPC Acrylic top, MCP355, D-TEK FuZion v2,XSPC RS360 Black,swiftech MCW60,D-TEK FuZion GFX+uni sink,EK-NB S-MAX
Server/htpc: Zotac GeForce 9300-ITX-I-E - E5200 - 4gb ddr2 800 - 2* 1.5tb f2 drives- Pico PSU - minja


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group