It is currently Tue Sep 02, 2014 4:38 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: 2nd GPU fan speed
PostPosted: Tue Oct 16, 2012 12:09 am 
Offline

Joined: Tue Jun 20, 2006 3:27 am
Posts: 5
Location: Romania
Hi everyone,

I'm asking about the GPU fans on a 2(or more)-card SLI/Crossfire setup before Windows loads. Do the secondary cards boot with full-speed fans or all of the cards are set low?

I'm using an experimental gaming rig consisting of booting with an Intel SB GPU into linux with a secondary Radeon 5850 for vitualization purpose (gaming in a guest Win7 VM, to be explicite).
The reason for the topic is that my Radeon starts with it's fan at 100% (since it's BIOS/firmware is not executed) and I actually load the linux radeon driver (and then unload it) just tu shut it up. I'm looking for a 7950 upgrade, and I wonder if this 100% fan booting is present on all cards (when not primary).

Please note: I'm interested in secondary cards only, no single-card experiences please.

_________________
Coolermaster Centurion 590
Corsair 450HX
Intel i5-2500 (non-K)
Asrock Z68-Extreme4
AMD Radeon 5850 (Gigabyte, VT-d)
Intel 320 120GB
Hercules Fortissimo IV (VT-d)
Dell U2312HM


Top
 Profile  
 
 Post subject: Re: 2nd GPU fan speed
PostPosted: Tue Oct 16, 2012 12:32 am 
Offline

Joined: Mon Mar 17, 2008 1:49 pm
Posts: 1193
Location: UK
mathew7 wrote:
The reason for the topic is that my Radeon starts with it's fan at 100% (since it's BIOS/firmware is not executed) and I actually load the linux radeon driver (and then unload it) just tu shut it up.

The BIOS is actually being loaded but is probably set to run fans at 100% until the driver is loaded. This is quite common and works the same regardless of how many GPUs you have. Running the fan at 100% until the driver is loaded does sound like overkill. You could try using RaBiT (might work under Wine but I would suggest using Windows if you can as you don't want to get it wrong) to change the BIOS fan speed settings so that it does run at 100% before the driver is loaded. You can then flash this back on to the card and see what the effect is. You may need a floppy disk drive to do this.

_________________
Silverstone SG03B: E8200, Asus P5E-VM HDMI, 2Gb RAM, Leadtek 9600GT+S1 rev. 2, Samsung 500Gb, Seasonic X-400, 2x Akasa 120mm, Scythe Zipang 2 fanless


Top
 Profile  
 
 Post subject: Re: 2nd GPU fan speed
PostPosted: Tue Oct 16, 2012 3:46 am 
Offline

Joined: Tue Jun 20, 2006 3:27 am
Posts: 5
Location: Romania
edh wrote:
The BIOS is actually being loaded but is probably set to run fans at 100% until the driver is loaded.

Not true... Only 1 GPU BIOS is loaded, and that is for the POST-showing card. It's the reason you can choose between "onboard", "PCI" and "PCI Express". And if I set to boot with the 5850, then the fans are only 1-2 secs at 100%, same as with a restart/reset. But my previous GTX260 did not have those 1-2 100% secs (that was way before my current usage pattern).
PS: I know about BIOS tweakings...I've done it (underclocked this card while I was using it in a MicroATX case). But it does not work on secondary card.

_________________
Coolermaster Centurion 590
Corsair 450HX
Intel i5-2500 (non-K)
Asrock Z68-Extreme4
AMD Radeon 5850 (Gigabyte, VT-d)
Intel 320 120GB
Hercules Fortissimo IV (VT-d)
Dell U2312HM


Top
 Profile  
 
 Post subject: Re: 2nd GPU fan speed
PostPosted: Tue Oct 16, 2012 5:51 am 
Offline

Joined: Mon Mar 17, 2008 1:49 pm
Posts: 1193
Location: UK
mathew7 wrote:
But my previous GTX260 did not have those 1-2 100% secs (that was way before my current usage pattern).

OK, we may have crossed purposes here. My understanding with NVIDIA cards is as you state above, what you have found with an ATI card looks to be different. How the cards chose to boot and run their fan speeds before and after hand may vary. Still have you actually tried modding the BIOS to look and see if any of the fan speeds are useful?

Which driver are you using? The Catalyst or one of the open source drivers? When are you loading the driver? If you modprobe the driver as soon as you can in the boot process is this a help by reducing the noisy fan time?

Why do you actually need this configuration?

_________________
Silverstone SG03B: E8200, Asus P5E-VM HDMI, 2Gb RAM, Leadtek 9600GT+S1 rev. 2, Samsung 500Gb, Seasonic X-400, 2x Akasa 120mm, Scythe Zipang 2 fanless


Top
 Profile  
 
 Post subject: Re: 2nd GPU fan speed
PostPosted: Tue Oct 16, 2012 6:21 am 
Offline

Joined: Tue Jun 20, 2006 3:27 am
Posts: 5
Location: Romania
Drivers are not an issue. I just detailed my use case, which is extremely rare. But the booting part is similar to multi-GPU configurations.

So I am asking crossfire (and maybe SLI) users of their GPU noise before Windows loads.
I gave the GTX260 example because I remember that it did not fully spinup before SW (firmware) started controlling it, which my Radeon (built by/for Gigabyte) does. And I want to know of other cards that are silent at boot, specifically 7950s.

_________________
Coolermaster Centurion 590
Corsair 450HX
Intel i5-2500 (non-K)
Asrock Z68-Extreme4
AMD Radeon 5850 (Gigabyte, VT-d)
Intel 320 120GB
Hercules Fortissimo IV (VT-d)
Dell U2312HM


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group