It is currently Wed Jul 30, 2014 4:05 pm

All times are UTC - 8 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: ssd alignment with Ranish PM
PostPosted: Thu Jun 13, 2013 10:27 pm 
Offline

Joined: Thu Jun 13, 2013 9:50 pm
Posts: 2
Hello,
I have bought a Plextor ssd (m5s-120GB) and I need some help in partitioning it in Ranish Partition Manager for win xp sp3.
Found this thread- viewtopic.php?t=55530 ; wherein cmthompson says " ....a program on the Ultimate Boot CD, called Ranish that will create a partition on an arbitrary C/H/S boundary. The correct values to use are 0/16/17, which equals 512 KB....."

Then below CTT replies as "I think MS recommends a 2048-sector alignment (1 MB) and Windows Vista also aligns at 1 MB by default during installation (if you have an unpartitioned drive) so I would also go for this value "just in case" - a 1 MB aligned partition is also 512 KB aligned, but not the other way around; seems that the erase block size for most flash chips is 512KB."

Now my questions:

1. What are the C/H/S values for 1mb alignment (instead of 0/16/17) ?

2. This 0/16/17 is, I suppose, the 1st 3 numbers in RPM i.e. the start of a partition. What should the last 3 numbers in RPM i.e. end of the partition (rather, what should be the last 2 numbers, as the 4th number will depend on size of the partition?)?

3. Has my system (c) partition to be the 1st partition in RPM, compulsorily ( i prefer to have a small dos/fat16 24mb partition as 1st partition in RPM)?

4. After getting the partition offset number (of the partition) in xp, what is the number to divide it with ( so that result is a whole number), so that it confirms I have a 1mb aligned partition?

Thanks


Top
 Profile  
 
 Post subject: Re: ssd alignment with Ranish PM
PostPosted: Fri Jun 14, 2013 7:30 pm 
Offline

Joined: Thu Jun 13, 2013 9:50 pm
Posts: 2
Did some experimenting (savepart, latest mini partn. tool wizard 7.8, AS program).

Q1 & 2) 0/65/2.

here are my 1st 3 rows (had to use F4 also in RPM).

0 0 1 0 0 1 0
0 0 2 0 65 1 2047
0 65 2 892 254 63 7,.....

Checked with AS benchmark program.It shows green-ok. But it says BAD for pciide (have a 300 GB ide seagate disk and a samsung sata 40GB disk). While installing winxp sp3, only Plextor was connected to the MB(GA41m-es2l). Hover balloon shows intel 82801GB/GR/GH sata controller and 27C0. While installing xp (not on aligned partn.), bios option was on enhanced sata mode.
How do i solve this pciide problem?
Thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group