"Your connection is not private" Cannot access certain websites anymore.

Offloading HDDs and other functions to remote NAS or servers is increasingly popular
Post Reply
Posts: 1
Joined: Mon Nov 09, 2020 5:00 am

"Your connection is not private" Cannot access certain websites anymore.

Post by kedimailo83 » Mon Nov 09, 2020 5:20 am

First of all, I am running Windows 7 off a Dell Optiplex 790. Intel i7 CPU, with a GTX 960. Not sure any other hardware would be relevant to the problem.

Starting yesterday, I had this problem returning to my computer. Certain websites would restrict my access such as: Reddit, Facebook, YouTube. It would give me the error of "Your connection is not private" It gives the generic error message, with the code "NET::ERR_CERT_AUTHORITY_INVALID"

The weird part, is that it is only affecting one of my machines in my household, and that it only restricts certain sites. It seems to be mainly affecting websites with a SSL, [mod: unknown url's deleted] but I can still access some sites that do, such as Netflix, IMDB, etc.

Well, I tried to Google some ideas, and so far what I came up with (and already tried), is making sure that the date/time on the machine is correct, clearing the SSL cache, resetting Chrome's setting (and, I'll also mention that Internet Explorer is the same way, so I don't think the problem lies solely with Chrome). I ran scans with Avast and MalwareBytes, which didn't pop anything. My called my ISP (Spectrum) to see if there was an issue which yielded no results (to no ones surprise). Lastly, I tried to rollback to a previous update with System Restore to several days ago, and it didn't do any good. I'm really baffled as to what is going on.
Please help..
Last edited by kedimailo83 on Wed Nov 11, 2020 2:18 am, edited 1 time in total.

Olle P
Posts: 711
Joined: Tue Nov 04, 2008 6:03 am
Location: Sweden

Re: "Your connection is not private" Cannot access certain websites anymore.

Post by Olle P » Mon Nov 09, 2020 11:05 pm

Disclaimer: I'm by no means an expert on this.

To me it seems like the problem stems from your browsers not recognising the provider of the affected certificates. (That's why you still can access sites with certificates from other providers.)
Most browsers will allow you access anyway, but it takes a few more steps when you get the error message: Click "Learn more" in the pop-up and then opt to "continue at your own risk" (or something to that effect).

Now the question is why the browsers don't recognice the providers.
* Are the browsers updated?
* Is your OS updated (as far as MS allows)?
* Where are you located (what nation)?

Post Reply